fs: build host-mkpasswd when BR2_ROOTFS_USERS_TABLES is used
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Jul 2015 15:36:07 +0000 (17:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Jul 2015 21:12:52 +0000 (23:12 +0200)
The code in fs/common.mk properly triggers the build of host-mkpasswd
when at least one package specifies a <pkg>_USERS variable. However,
when no selected package specifies a <pkg>_USERS variable but the user
uses a custom users table through BR2_ROOTFS_USERS_TABLES, then we
forget to build host-mkpasswd, leading to build failures if you don't
have mkpasswd installed in your machine.

This commit fixes that by taking into account both the package users
table and the custom users table when deciding to depend or not on
host-mkpasswd.

Reported-by: Auke Willem Oosterhoff <oosterhoff@baopt.nl>
Cc: Auke Willem Oosterhoff <oosterhoff@baopt.nl>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
fs/common.mk

index 4387d069a14b48d42d5396d51f5d7beda1d7bbc7..ad1bcf3034bc4400d5617d1bc99bf5c8b79939f3 100644 (file)
@@ -41,7 +41,7 @@ define ROOTFS_TARGET_INTERNAL
 
 # extra deps
 ROOTFS_$(2)_DEPENDENCIES += host-fakeroot host-makedevs \
-       $$(if $$(PACKAGES_USERS),host-mkpasswd)
+       $$(if $$(PACKAGES_USERS)$$(ROOTFS_USERS_TABLES),host-mkpasswd)
 
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)_GZIP),y)
 ROOTFS_$(2)_COMPRESS_EXT = .gz