zstd: install to staging directory
authorChris Packham <judge.packham@gmail.com>
Mon, 16 Oct 2017 21:59:02 +0000 (10:59 +1300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 15:19:32 +0000 (17:19 +0200)
Install libzstd to the staging directory.

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/zstd/zstd.mk

index 089d654749ca53e4aa24df09f1d1debd079155a8..f149ad2f9132c4582515c9f54039d343ef527ade 100644 (file)
@@ -6,6 +6,7 @@
 
 ZSTD_VERSION = v1.3.2
 ZSTD_SITE = $(call github,facebook,zstd,$(ZSTD_VERSION))
+ZSTD_INSTALL_STAGING = YES
 ZSTD_LICENSE = BSD-3-Clause, GPL-2.0
 ZSTD_LICENSE_FILES = LICENSE COPYING
 
@@ -46,4 +47,9 @@ define ZSTD_INSTALL_TARGET_CMDS
                DESTDIR=$(TARGET_DIR) PREFIX=/usr -C $(@D)/programs install
 endef
 
+define ZSTD_INSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) $(ZSTD_OPTS) \
+               DESTDIR=$(STAGING_DIR) PREFIX=/usr -C $(@D)/lib install
+endef
+
 $(eval $(generic-package))