dbus: enable systemd support
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Thu, 3 Jul 2014 16:57:34 +0000 (18:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 21:27:16 +0000 (23:27 +0200)
Enable systemd support if systemd is selected as init system (require
systemd compatibility libraries).

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dbus/Config.in
package/dbus/dbus.mk

index 653f7482f6931c6fe0219eda6654a6e85f90e9be..7d49ce5047bc18c94c5f95235c70a345b80e0883 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_DBUS
        # uses fork()
        depends on BR2_USE_MMU
        select BR2_PACKAGE_EXPAT
+       select BR2_PACKAGE_SYSTEMD_COMPAT if BR2_INIT_SYSTEMD
        help
          The D-Bus message bus system.
 
index 429c9230c045ef48bf346d0681885251aea0100a..63cec6e46941de7b2ede7dfae3bf605e48138fdc 100644 (file)
@@ -50,8 +50,13 @@ else
 DBUS_CONF_OPT += --without-x
 endif
 
-ifeq ($(BR2_PACKAGE_SYSTEMD),y)
-DBUS_CONF_OPT += --with-systemdsystemunitdir=/lib/systemd/system
+ifeq ($(BR2_INIT_SYSTEMD),y)
+DBUS_CONF_OPT += \
+       --enable-systemd \
+       --with-systemdsystemunitdir=/lib/systemd/system
+DBUS_DEPENDENCIES += systemd
+else
+DBUS_CONF_OPT += --disable-systemd
 endif
 
 # fix rebuild (dbus makefile errors out if /var/lib/dbus is a symlink)