pciutils: fixup library permissions
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 18 Sep 2013 13:38:03 +0000 (10:38 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Sep 2013 14:57:23 +0000 (16:57 +0200)
libpci.so* is installed without +x permissions thus preventing
stripping. Fix it up in the post install target hooks.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pciutils/pciutils.mk

index 350ca0d352ce65b6271ceea6af1cfb59abbf0e2d..fd6f8aa57d31e71c218c167df24827be0baa685b 100644 (file)
@@ -65,4 +65,12 @@ define PCIUTILS_INSTALL_STAGING_CMDS
                SHARED=$(PCIUTILS_SHARED) install install-lib
 endef
 
+
+# Library lacks +x so strip skips it
+define PCIUTILS_FIX_LIBRARY_MODE
+       -chmod +x $(TARGET_DIR)/usr/lib/libpci.so*
+endef
+
+PCIUTILS_POST_INSTALL_TARGET_HOOKS += PCIUTILS_FIX_LIBRARY_MODE
+
 $(eval $(generic-package))