package/file: zlib is optional, not mandatory
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 1 Feb 2020 11:04:26 +0000 (12:04 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 1 Feb 2020 11:36:48 +0000 (12:36 +0100)
zlib is optional since version 4.22 and
https://github.com/file/file/commit/b950f1f426f8855e69d6f3dcc32067e931e015b7
and --enable-zlib has been fixed since version 5.37 and
https://github.com/file/file/commit/8c6dcd7ef690e90a3e897e8f886513750ed2c04d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/file/Config.in
package/file/file.mk

index 13934b22395866ea6167576af4c1b869cbe90e31..edc4d874b216287c62bce1f38a348df871c2b6bd 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_FILE
        bool "file"
-       select BR2_PACKAGE_ZLIB
        help
          Program to identify a file's format by scanning binary data
          for known patterns.
index cff59c86adbc777df51ad728da75c0f1098de8f1..42f9524ed191c916e0318cc5d5651a708a8bc1cc 100644 (file)
@@ -6,7 +6,7 @@
 
 FILE_VERSION = 5.38
 FILE_SITE = ftp://ftp.astron.com/pub/file
-FILE_DEPENDENCIES = host-file zlib
+FILE_DEPENDENCIES = host-file
 HOST_FILE_DEPENDENCIES = host-zlib
 FILE_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 FILE_INSTALL_STAGING = YES
@@ -37,5 +37,12 @@ else
 FILE_CONF_OPTS += --disable-xzlib
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+FILE_CONF_OPTS += --enable-zlib
+FILE_DEPENDENCIES += zlib
+else
+FILE_CONF_OPTS += --disable-zlib
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))