vlc: set back upnp support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 18 Dec 2017 21:52:06 +0000 (22:52 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 19 Dec 2017 08:53:34 +0000 (09:53 +0100)
Commit cb7aa25df8c3c4531354fd0f7d69208f89360c7b has disabled upnp support
as --disable-upnp and --enable-upnp are both set if libupnp or libupnp18
is enabled

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/vlc.mk

index febd9e0319cbf3f271dac75e4bd7d8e6b8f109c3..56bfdced53ef7324b6edbd8ed8b0740fbf196ac0 100644 (file)
@@ -281,16 +281,9 @@ else
 VLC_CONF_OPTS += --disable-theora
 endif
 
-ifeq ($(BR2_PACKAGE_LIBUPNP),y)
+ifeq ($(BR2_PACKAGE_LIBUPNP)$(BR2_PACKAGE_LIBUPNP18),y)
 VLC_CONF_OPTS += --enable-upnp
-VLC_DEPENDENCIES += libupnp
-else
-VLC_CONF_OPTS += --disable-upnp
-endif
-
-ifeq ($(BR2_PACKAGE_LIBUPNP18),y)
-VLC_CONF_OPTS += --enable-upnp
-VLC_DEPENDENCIES += libupnp18
+VLC_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBUPNP),libupnp,libupnp18)
 else
 VLC_CONF_OPTS += --disable-upnp
 endif