sdl: use <pkg>_CONFIG_SCRIPTS for sdl-config
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Mar 2013 22:36:19 +0000 (22:36 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 18 Mar 2013 08:46:31 +0000 (09:46 +0100)
Use the <pkg>_CONFIG_SCRIPTS mechanism to handle the sdl-config
script, so that it properly gets removed from the target. However, we
can't completely remove the manual fixup, because it also takes care
of removing the -Wl,-rpath option, which the general
<pkg>_CONFIG_SCRIPTS doesn't do.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sdl/sdl.mk

index 4786dc5d75e33857ed0b1d76213c28f05c67c499..fb47c4d19edb6c45f9613af5d6d2a686c208949a 100644 (file)
@@ -57,13 +57,10 @@ SDL_CONF_OPT += --enable-pulseaudio=no \
                --disable-nasm \
                --disable-video-ps3
 
-# Fixup prefix= and exec_prefix= in sdl-config, and remove the
-# -Wl,-rpath option.
+SDL_CONFIG_SCRIPTS = sdl-config
+
+# Remove the -Wl,-rpath option.
 define SDL_FIXUP_SDL_CONFIG
-       $(SED) 's%prefix=/usr%prefix=$(STAGING_DIR)/usr%' \
-               $(STAGING_DIR)/usr/bin/sdl-config
-       $(SED) 's%exec_prefix=/usr%exec_prefix=$(STAGING_DIR)/usr%' \
-               $(STAGING_DIR)/usr/bin/sdl-config
        $(SED) 's%-Wl,-rpath,\$${libdir}%%' \
                $(STAGING_DIR)/usr/bin/sdl-config
 endef