Makefile: revert HOST_GLIB_BIN staging_dir fix (r23920,23923)
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 7 Nov 2008 08:57:59 +0000 (08:57 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 7 Nov 2008 08:57:59 +0000 (08:57 -0000)
It causes more trouble than it's worth, and we should move to building those
host tools ourselves to not get into version issues anyway.

Makefile

index 0b27ed1fc772b88ce5c97f09be27eba472889528..bd3c7c92eb8fd8d80b732217f75dd0622c2d5e91 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -122,8 +122,7 @@ HOSTCPP:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCPP)" || type -p $(HOSTCPP) ||
 HOSTLD:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLD)" || type -p $(HOSTLD) || echo ld)
 HOSTLN:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLN)" || type -p $(HOSTLN) || echo ln)
 HOSTNM:=$(shell $(CONFIG_SHELL) -c "which $(HOSTNM)" || type -p $(HOSTNM) || echo nm)
-# ignore version in staging_dir
-HOST_GLIB_BIN:=`dirname $(shell $(CONFIG_SHELL) -c "(which -a glib-genmarshal; echo /usr/bin/glib-genmarshal)|grep -v $(BR2_STAGING_DIR)|head -n 1")`
+HOST_GLIB_BIN:=`dirname $(shell $(CONFIG_SHELL) -c "which glib-genmarshal" || echo /usr/bin/glib-genmarshal)`
 HOST_GLIB:=$(shell $(CONFIG_SHELL) -c "dirname $(HOST_GLIB_BIN)" || echo /usr)