package/mtd: test programs need threads
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 15 Aug 2017 04:20:04 +0000 (06:20 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 15 Aug 2017 16:05:08 +0000 (18:05 +0200)
The test programs depend on pthreads:
http://git.infradead.org/mtd-utils.git/blob/1bfee8660131fca7a18f68e9548a18ca6b3378a0:/configure.ac#l43

Also propagate the threads dependency to BR2_PACKAGE_MTD_INTEGCK.

Fixes
http://autobuild.buildroot.net/results/879/879c79e505f65387a46c4be263dc8783c8ca61bf/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Arnout: add depends on BR2_USE_MMU to comment]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/mtd/Config.in

index a1df4cfc0ad1fa9421a486b5d65ea8bc49d63f59..37e4b4ab1bbea123ae9ab1f75a9877a7d2417cc5 100644 (file)
@@ -24,6 +24,7 @@ config BR2_PACKAGE_MTD_UBIFS_UTILS
 
 config BR2_PACKAGE_MTD_TESTS
        bool
+       depends on BR2_TOOLCHAIN_HAS_THREADS
 
 comment "MTD tools selection"
 
@@ -174,9 +175,14 @@ config BR2_PACKAGE_MTD_UBIBLOCK
 
 config BR2_PACKAGE_MTD_INTEGCK
        bool "integck"
+       depends on BR2_TOOLCHAIN_HAS_THREADS # mtd-tests
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_MTD_TESTS
        help
          Install the integck test program.
 
+comment "integck needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
+
 endif