boot/boot-wrapper-aarch64: add gicv3 support
authorJan Kotas <jank@cadence.com>
Tue, 3 Dec 2019 09:18:15 +0000 (04:18 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 12 Dec 2019 20:22:27 +0000 (21:22 +0100)
This patch adds support for GICv3 (such as GIC-500).

Signed-off-by: Jan Kotas <jank@cadence.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/boot-wrapper-aarch64/Config.in
boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk

index efb70dcdf594fc4d84363935cc01e53ed98ae47c..cf7389282f2fe4710aea5f018a9a066877a262ac 100644 (file)
@@ -38,4 +38,9 @@ config BR2_TARGET_BOOT_WRAPPER_AARCH64_PSCI
          Boot secondary SMP cores using PSCI firmware calls. If
          disabled, the spin-table method is used instead.
 
+config BR2_TARGET_BOOT_WRAPPER_AARCH64_GICV3
+       bool "Enable GICv3 instead of GICv2"
+       help
+         Boot using GICv3 instead of GICv2.
+
 endif
index b0bba7a4de0e828e17195618e7177a86aba51f34..117e1139845e5ed05e8d82bce56e7269c3dce3e6 100644 (file)
@@ -28,6 +28,10 @@ else
 BOOT_WRAPPER_AARCH64_CONF_OPTS += --disable-psci
 endif
 
+ifeq ($(BR2_TARGET_BOOT_WRAPPER_AARCH64_GICV3),y)
+BOOT_WRAPPER_AARCH64_CONF_OPTS += --enable-gicv3
+endif
+
 # We need to convince the configure script that the Linux kernel tree
 # exists, as well as the DTB and the kernel Image. Even though those
 # are available on the build machine, the configure script uses