projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9cee918
)
teach libtool to use the correct system compiler
author
Eric Andersen
<andersen@codepoet.org>
Wed, 5 Feb 2003 10:43:44 +0000
(10:43 -0000)
committer
Eric Andersen
<andersen@codepoet.org>
Wed, 5 Feb 2003 10:43:44 +0000
(10:43 -0000)
make/libtool.mk
patch
|
blob
|
history
diff --git
a/make/libtool.mk
b/make/libtool.mk
index aa754a92303c799db996827380ebba0085a6b00a..53038cbae460bab692e0b1720d4d4154ca5ee63c 100644
(file)
--- a/
make/libtool.mk
+++ b/
make/libtool.mk
@@
-58,6
+58,8
@@
$(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
mandir=$(TARGET_DIR)/usr/man \
includedir=$(TARGET_DIR)/usr/include \
-C $(LIBTOOL_DIR) install;
+ perl -pi -e "s,^CC.*,CC=\"/usr/bin/gcc\"," $(TARGET_DIR)/usr/bin/libtool
+ perl -pi -e "s,^LD.*,CC=\"/usr/bin/ld\"," $(TARGET_DIR)/usr/bin/libtool
rm -rf $(TARGET_DIR)/share/locale
libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)