package/iputils: fix IPUTILS_PERMISSIONS
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 17 Jun 2019 17:17:47 +0000 (19:17 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 17 Jun 2019 21:21:34 +0000 (23:21 +0200)
The IPUTILS_PERMISSIONS variable was wrong, because iputils installs
its programs in /usr/bin, not in /bin. It probably was only tested
with the merged /usr option enabled.

This commit fixes IPUTILS_PERMISSIONS, taking into account the change
done in 6e18892733 "package/iputils: move binaries to the location also
used by Busybox":

 - arping is moved by the post-install target hook to /usr/sbin

 - clockdiff is installed by iputils in /usr/bin

 - ping is moved by the post-install target hook to /bin, which makes
   the previously incorrect path in IPUTILS_PERMISSIONS now correct

Fixes:

  http://autobuild.buildroot.net/results/fe378bca29c86a681ba9ad40386cb89248195c50/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/iputils/iputils.mk

index 7bd756f0400a84cb2dfc921caf2abd03637db40a..052110878a51773b7cf771c84e94188adb695a79 100644 (file)
@@ -66,9 +66,9 @@ IPUTILS_POST_INSTALL_TARGET_HOOKS += IPUTILS_MOVE_BINARIES
 # handle permissions ourselves
 IPUTILS_CONF_OPTS += -DNO_SETCAP_OR_SUID=true
 define IPUTILS_PERMISSIONS
-       /bin/arping      f 4755 0 0 - - - - -
-       /bin/clockdiff   f 4755 0 0 - - - - -
-       /bin/ping        f 4755 0 0 - - - - -
+       /usr/sbin/arping      f 4755 0 0 - - - - -
+       /usr/bin/clockdiff    f 4755 0 0 - - - - -
+       /bin/ping             f 4755 0 0 - - - - -
 endef
 
 $(eval $(meson-package))