package/gd: Add dependency to libvpx
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 10 Apr 2015 17:22:10 +0000 (19:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 10 Apr 2015 19:54:10 +0000 (21:54 +0200)
Needed to get reproducable builds and to reproduce this build error:
http://autobuild.buildroot.net/results/046/046dd505feb5e92bdee3d0993366be162da1223a/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gd/gd.mk

index 2991cd5a76c9d0928b579c7b5eb0e19998386843..1b519de4e1bf992ff03ba849c387929f8fdc8687 100644 (file)
@@ -51,6 +51,13 @@ else
 GD_CONF_OPTS += --without-png
 endif
 
+ifeq ($(BR2_PACKAGE_LIBVPX),y)
+GD_DEPENDENCIES += libvpx
+GD_CONF_OPTS += --with-vpx
+else
+GD_CONF_OPTS += --without-vpx
+endif
+
 ifeq ($(BR2_PACKAGE_TIFF),y)
 GD_DEPENDENCIES += tiff
 GD_CONF_OPTS += --with-tiff