package: add gmpc (gtk musicpd client) package
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Dec 2008 20:54:40 +0000 (20:54 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Dec 2008 20:54:40 +0000 (20:54 -0000)
package/Config.in
package/gmpc/Config.in [new file with mode: 0644]
package/gmpc/gmpc.mk [new file with mode: 0644]

index 9569e411a312b3449a407c04e5bc5f64f450fe20..ace447dfb7f8ae71dd60c81432744e36e0222c9a 100644 (file)
@@ -372,6 +372,7 @@ source "package/alsamixergui/Config.in"
 source "package/dillo/Config.in"
 source "package/docker/Config.in"
 source "package/gqview/Config.in"
+source "package/gmpc/Config.in"
 source "package/gtkperf/Config.in"
 source "package/leafpad/Config.in"
 source "package/midori/Config.in"
diff --git a/package/gmpc/Config.in b/package/gmpc/Config.in
new file mode 100644 (file)
index 0000000..74fd094
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_GMPC
+       bool "gmpc"
+       depends on BR2_PACKAGE_LIBGTK2
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_GETTEXT
+       select BR2_PACKAGE_LIBINTL
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+       select BR2_PACKAGE_PKGCONFIG
+       select BR2_PACKAGE_LIBMPD
+       select BR2_PACKAGE_LIBCURL
+       help
+         Gnome Music Player Client is a GNOME/GTK2.2 client for
+         Music Player Daemon.
+
+         http://gmpcwiki.sarine.nl/index.php?title=GMPC
diff --git a/package/gmpc/gmpc.mk b/package/gmpc/gmpc.mk
new file mode 100644 (file)
index 0000000..29490f3
--- /dev/null
@@ -0,0 +1,17 @@
+#############################################################
+#
+# gmpc
+#
+#############################################################
+GMPC_VERSION = 0.17.0
+GMPC_SOURCE = gmpc-$(GMPC_VERSION).tar.gz
+GMPC_SITE = http://download.sarine.nl/download/Programs/gmpc/$(GMPC_VERSION)/
+GMPC_LIBTOOL_PATCH = NO
+GMPC_CONF_ENV = ac_cv_lib_curl_curl_global_init=yes
+GMPC_CONF_OPT = --disable-mmkeys $(DISABLE_NLS)
+
+
+GMPC_DEPENDENCIES = libglib2 libgtk2 libcurl libmpd
+
+
+$(eval $(call AUTOTARGETS,package,gmpc))