jimtcl: explicitly set --host / --build
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 3 Nov 2017 22:28:37 +0000 (23:28 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 5 Nov 2017 19:44:08 +0000 (20:44 +0100)
Fixes:
http://autobuild.buildroot.net/results/d13/d137680bf1c0ebfacef635cb2f0fc14524759143/

Otherwise the (handwritten) configure script uses a config.guess script from
2010 to figure out the build host, breaking builds on ppc64le hosts.

The result of --host / --build is only used to detect if we are building for
Windows or not, which is why things are working on x86(-64) build hosts
without specifying --host even though we are cross compiling - But this may
change in the future, so we better pass the correct values.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jimtcl/jimtcl.mk

index cdbf8ae477e1b7f25d1ae1f2e62dcaad7f95d20f..313970d94a13daf754149332f1a66866a82876f1 100644 (file)
@@ -42,6 +42,8 @@ define JIMTCL_CONFIGURE_CMDS
        (cd $(@D); \
                $(TARGET_CONFIGURE_OPTS) CCACHE=none \
                ./configure --prefix=/usr \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
                $(JIMTCL_SHARED) \
        )
 endef