gcc: do not pass --with-pkgversion to gcc < 4.3
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Dec 2009 11:03:05 +0000 (12:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Dec 2009 11:03:05 +0000 (12:03 +0100)
Commit 09c181f2891276c458de327d241151bab38bde0f added new options
passed to gcc configure to set --with-pkgversion and --with-bugurl, to
gcc >= gcc 4.3. To check this, it was checking that the GCC_VERSION
string does not contain 4.2.

Unfortunately, the test is bogus. It does a findstring on x4.2. (with
a final dot) but compares the result with x4.2 (without the final
dot).

The result is that even with 4.2 versions, the test was true, leading
--with-pkgversion and --with-bugurl being passed to gcc's configure
script.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/gcc/gcc-uclibc-4.x.mk

index 32f7a1e45fe1140460ddd5fff196627a6a90f0a8..6f65cb35fbd616e6d115eb10d9b4fc3e3733bafa 100644 (file)
@@ -45,7 +45,7 @@ GCC_NO_MPFR:=y
 endif
 
 # Branding works on >= 4.3
-ifneq ($(findstring x4.2.,x$(GCC_VERSION)),x4.2)
+ifneq ($(findstring x4.2.,x$(GCC_VERSION)),x4.2.)
 BUILDROOT_VERSION_STRING=$(call qstrip,$(BR2_VERSION))
 EXTRA_GCC_CONFIG_OPTIONS+=--with-pkgversion="Buildroot $(BUILDROOT_VERSION_STRING)" \
        --with-bugurl="http://bugs.buildroot.net/"