package/rtai: require kernel modules from Kconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 10 Dec 2015 18:53:17 +0000 (19:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 Dec 2015 22:52:34 +0000 (23:52 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rtai/Config.in
package/rtai/rtai.mk

index ecbff38d470be7c2bcccf144a60e80d6e0de9416..14b1854837e568a3ec61d8f7667e7ddbfb81cb8b 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_RTAI
        bool "rtai"
        depends on BR2_LINUX_KERNEL_EXT_RTAI
+       select BR2_LINUX_NEEDS_MODULES # not using kernel-module infra
        help
          RTAI - the RealTime Application Interface for Linux.
 
index 6e803a6ade3e1f214d141f27a230890a02adbe2c..dfd8e0c19082621de88c160d4e059386d8b8cbbf 100644 (file)
@@ -18,12 +18,6 @@ RTAI_POST_INSTALL_STAGING_HOOKS += RTAI_POST_PATCH_FIXUP
 
 RTAI_DEPENDENCIES = linux
 
-# We're building a kernel module without using the kernel-module infra,
-# so we need to tell we want module support in the kernel
-ifeq ($(BR2_PACKAGE_RTAI),y)
-LINUX_NEEDS_MODULES = y
-endif
-
 RTAI_CONF_OPTS = \
        --includedir=/usr/include/rtai \
        --with-linux-dir=$(LINUX_DIR)   \