screen: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:57 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:36:39 +0000 (00:36 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/screen/screen.mk

index 461bce27c92affe68cbfb1f0ef40f14b01aa4af9..827e776fe7a0d4fb21a09fda3c1b1481f6919746 100644 (file)
@@ -15,9 +15,7 @@ SCREEN_MAKE = $(MAKE1)
 SCREEN_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) SCREEN=screen install_bin
 
 define SCREEN_INSTALL_SCREENRC
-       if [ ! -f $(TARGET_DIR)/etc/screenrc ]; then \
-               $(INSTALL) -m 0755 -D $(@D)/etc/screenrc $(TARGET_DIR)/etc/screenrc; \
-       fi
+       $(INSTALL) -m 0755 -D $(@D)/etc/screenrc $(TARGET_DIR)/etc/screenrc
 endef
 
 SCREEN_POST_INSTALL_TARGET_HOOKS += SCREEN_INSTALL_SCREENRC