Use relative links
authorEric Andersen <andersen@codepoet.org>
Wed, 28 Jul 2004 19:26:04 +0000 (19:26 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 28 Jul 2004 19:26:04 +0000 (19:26 -0000)
make/ncurses.mk
make/zlib.mk

index d0e401a6bae73c7b27ada5d17d72e58d796d616b..1768c1e4e314b5c8583d5fad483d9e4325f678b3 100644 (file)
@@ -5,7 +5,7 @@
 #
 #############################################################
 # Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.32 2003/11/19 17:17:54 andersen Exp $
+# $Id: ncurses.mk,v 1.33 2004/07/28 19:26:04 andersen Exp $
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU Library General Public License as
@@ -112,7 +112,7 @@ $(TARGET_DIR)/usr/lib/libncurses.a: $(STAGING_DIR)/lib/libncurses.a
        (cd $(TARGET_DIR)/usr/lib; ln -fs libncurses.a libtermcap.a)
        (cd $(TARGET_DIR)/usr/include; ln -fs ncurses.h curses.h)
        rm -f $(TARGET_DIR)/lib/libncurses.so
-       (cd $(TARGET_DIR)/usr/lib; ln -fs /lib/libncurses.so.5.2 libncurses.so)
+       (cd $(TARGET_DIR)/usr/lib; ln -fs ../../lib/libncurses.so.5.2 libncurses.so)
        -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libncurses.so.5.2
        touch -c $(TARGET_DIR)/usr/lib/libncurses.a
 
index 30e6a7c6f765a1faf16a011c44c00b4d3feeb4d9..3f23413a2c5c360b21c76aee446a1808e5e55167 100644 (file)
@@ -54,7 +54,7 @@ $(TARGET_DIR)/usr/lib/libz.a: $(STAGING_DIR)/lib/libz.so.1.1.4
        cp -dpf $(STAGING_DIR)/include/zconf.h $(TARGET_DIR)/usr/include/
        cp -dpf $(STAGING_DIR)/lib/libz.a $(TARGET_DIR)/usr/lib/
        rm -f $(TARGET_DIR)/lib/libz.so
-       (cd $(TARGET_DIR)/usr/lib; ln -fs /lib/libz.so.1.1.4 libz.so)
+       (cd $(TARGET_DIR)/usr/lib; ln -fs ../../lib/libz.so.1.1.4 libz.so)
        touch -c $(TARGET_DIR)/usr/lib/libz.a
 
 zlib-headers: $(TARGET_DIR)/usr/lib/libz.a