package/zeromq: allow building with draft APIs enabled
authorLionel Flandrin <lionel@svkt.org>
Tue, 5 Feb 2019 10:28:13 +0000 (11:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 16:19:53 +0000 (17:19 +0100)
Signed-off-by: Lionel Flandrin <lionel@svkt.org>
[Thomas: add explicit --disable-drafts]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/zeromq/Config.in
package/zeromq/zeromq.mk

index 69be9f002c593b8af5ec008cbe4054c7200b72e8..aeedff17b8e4729531c28c48e4e4813da27da046 100644 (file)
@@ -52,4 +52,11 @@ config BR2_PACKAGE_ZEROMQ_PGM
          3208) implemented either over raw IP packets or UDP
          datagrams (encapsulated PGM).
 
+config BR2_PACKAGE_ZEROMQ_DRAFTS
+       bool "Draft APIs support"
+       help
+         Enable unstable draft ZeroMQ APIs
+
+         https://pyzmq.readthedocs.io/en/latest/draft.html
+
 endif
index da57f8745c25f85db1ffbbb536f61b1a0de393ee..d799f863c406b97200d8505a805915309db7df7c 100644 (file)
@@ -47,6 +47,12 @@ else
 ZEROMQ_CONF_OPTS += --without-pgm
 endif
 
+ifeq ($(BR2_PACKAGE_ZEROMQ_DRAFTS),y)
+ZEROMQ_CONF_OPTS += --enable-drafts
+else
+ZEROMQ_CONF_OPTS += --disable-drafts
+endif
+
 # ZeroMQ uses libsodium if it's available.
 ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
 ZEROMQ_DEPENDENCIES += libsodium