uboot: simplify patch wildcard for BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 10 Apr 2013 22:16:10 +0000 (00:16 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 11 Apr 2013 05:47:54 +0000 (07:47 +0200)
To match the logic we have for BR2_LINUX_KERNEL_PATCH. The user has
already specified a custom patch directory, so we don't need to be
so specific about the what file names we accept, and it becomes quite
cumbersome when a custom git version is used.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/uboot/Config.in
boot/uboot/uboot.mk

index bc5ce19daa2ab238929dafca54530edc5d04cc0b..d377fd19860d371c25580cc88ef468fb47785e0a 100644 (file)
@@ -73,7 +73,7 @@ config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
        help
          If your board requires custom patches, add the path to the
          directory containing the patches here. The patches must be
-         named uboot-<version>-<something>.patch.
+         named uboot-<something>.patch.
 
          Most users may leave this empty
 
index c337e75527cc641480f88d1d0c9546a5a71f0355..004bdf2bc47656281e4baeb23a07a637d0f0f8fc 100644 (file)
@@ -64,7 +64,7 @@ endef
 ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
 define UBOOT_APPLY_CUSTOM_PATCHES
        support/scripts/apply-patches.sh $(@D) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) \
-               uboot-$(UBOOT_VERSION)-\*.patch
+               uboot-\*.patch
 endef
 
 UBOOT_POST_PATCH_HOOKS += UBOOT_APPLY_CUSTOM_PATCHES