linux: fix uImage location on AVR32
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Sep 2010 13:08:07 +0000 (15:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 28 Sep 2010 22:14:21 +0000 (00:14 +0200)
On most architectures, the kernel image can be found in
arch/<ARCH>/boot, but on AVR32, it's in arch/<ARCH>/boot/images.

Issue initially reported by Joachim Pihl
<joachim.pihl@sensordevelopments.com>.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 4490023a42e746dcd045b5e573541156fd590917..55dc2bfe883f31a6896f5a04d119fde48463fbcd 100644 (file)
@@ -42,7 +42,11 @@ else ifeq ($(BR2_LINUX_KERNEL_VMLINUX_BIN),y)
 LINUX26_IMAGE_NAME=vmlinux.bin
 endif
 
+ifeq ($(KERNEL_ARCH),avr32)
+LINUX26_IMAGE_PATH=$(LINUX26_DIR)/arch/$(KERNEL_ARCH)/boot/images/$(LINUX26_IMAGE_NAME)
+else
 LINUX26_IMAGE_PATH=$(LINUX26_DIR)/arch/$(KERNEL_ARCH)/boot/$(LINUX26_IMAGE_NAME)
+endif
 
 # Download
 $(LINUX26_DIR)/.stamp_downloaded: