linux/perf: conditionally enable support for gz/xz compression
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 11 Mar 2016 18:19:57 +0000 (19:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Mar 2016 13:38:14 +0000 (14:38 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux-tool-perf.mk

index d4b8f0ef60530fef8c99d6bf2346a766799db560..8143474b0a590ae3ca8839b57df99a15952ca1da 100644 (file)
@@ -75,6 +75,19 @@ else
 PERF_MAKE_FLAGS += NO_LIBELF=1 NO_DWARF=1
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+PERF_DEPENDENCIES += zlib
+else
+PERF_MAKE_FLAGS += NO_ZLIB=1
+endif
+
+# lzma is provided by xz
+ifeq ($(BR2_PACKAGE_XZ),y)
+PERF_DEPENDENCIES += xz
+else
+PERF_MAKE_FLAGS += NO_LZMA=1
+endif
+
 # We really do not want to build the perf documentation, because it
 # has stringent requirement on the documentation generation tools,
 # like xmlto and asciidoc), which may be lagging behind on some