skeleton: create include/ directory
authorBaruch Siach <baruch@tkos.co.il>
Mon, 14 May 2018 03:23:56 +0000 (06:23 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 19 May 2018 20:43:30 +0000 (22:43 +0200)
Don't rely on a random host package to create the include/ directory for
us. Some packages do the wrong thing since they implicitly assume that
this directory exists already. Commit a557aedad2 (zstd: fix host headers
installation) shows an example of that.

Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/skeleton/skeleton.mk

index efcf420d724333476b047c14824ed4564170dbb1..9d97f02f08bf2ab82e861586e9af0c9422dfb08b 100644 (file)
@@ -16,6 +16,7 @@ SKELETON_ADD_SKELETON_DEPENDENCY = NO
 define HOST_SKELETON_INSTALL_CMDS
        $(Q)ln -snf . $(HOST_DIR)/usr
        $(Q)mkdir -p $(HOST_DIR)/lib
+       $(Q)mkdir -p $(HOST_DIR)/include
        $(Q)case $(HOSTARCH) in \
                (*64) ln -snf lib $(HOST_DIR)/lib64;; \
                (*)   ln -snf lib $(HOST_DIR)/lib32;; \