package/skeleton-common: fix recursive variable
authorStefan Becker <chemobejk@gmail.com>
Thu, 3 Aug 2017 09:05:45 +0000 (12:05 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 3 Aug 2017 10:31:55 +0000 (12:31 +0200)
This fixes a recursive variable definition introduced by the refactoring
in commit 120307520f69f801bf05df1d2fd3433c6d498551. Simply rename the
hook to remove the recursion.

Fixes https://bugs.busybox.net/show_bug.cgi?id=10146

Signed-off-by: Stefan Becker <chemobejk@gmail.com>
package/skeleton-common/skeleton-common.mk

index e9b87c3fd32d57483839d6391b3c396a04e34761..e94dd6e14d1d0e0239d8b8ffb69cd5c5769247f0 100644 (file)
@@ -75,16 +75,16 @@ endef
 SKELETON_COMMON_TARGET_FINALIZE_HOOKS += SKELETON_COMMON_SET_ROOT_PASSWD
 
 ifeq ($(BR2_SYSTEM_BIN_SH_NONE),y)
-define SKELETON_COMMON_BIN_SH
+define SKELETON_COMMON_SET_BIN_SH
        rm -f $(TARGET_DIR)/bin/sh
 endef
 else
 ifneq ($(SKELETON_COMMON_BIN_SH),)
-define SKELETON_COMMON_BIN_SH
+define SKELETON_COMMON_SET_BIN_SH
        ln -sf $(SKELETON_COMMON_BIN_SH) $(TARGET_DIR)/bin/sh
 endef
 endif
 endif
-SKELETON_COMMON_TARGET_FINALIZE_HOOKS += SKELETON_COMMON_BIN_SH
+SKELETON_COMMON_TARGET_FINALIZE_HOOKS += SKELETON_COMMON_SET_BIN_SH
 
 $(eval $(generic-package))