libpng: bump to 1.4.4
authorMartin Banky <martin.banky@gmail.com>
Sun, 26 Sep 2010 07:19:58 +0000 (00:19 -0700)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 5 Oct 2010 20:25:06 +0000 (22:25 +0200)
Signed-off-by: Martin Banky <Martin.Banky@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libpng/libpng.mk

index 5608f4fce12cba1e9e369523fa93eeb8bc13f331..82b88da749310082d50f14e15c534ede88e73960 100644 (file)
@@ -3,23 +3,22 @@
 # libpng (Portable Network Graphic library)
 #
 #############################################################
-LIBPNG_VERSION:=1.2.44
+LIBPNG_VERSION = 1.4.4
+LIBPNG_SERIES = 14
 LIBPNG_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/libpng
 LIBPNG_SOURCE = libpng-$(LIBPNG_VERSION).tar.bz2
 LIBPNG_LIBTOOL_PATCH = NO
 LIBPNG_INSTALL_STAGING = YES
-LIBPNG_CONF_OPT = --without-libpng-compat
 LIBPNG_DEPENDENCIES = host-pkg-config zlib
 
-HOST_LIBPNG_CONF_OPT = --without-libpng-compat
 HOST_LIBPNG_DEPENDENCIES = host-pkg-config host-zlib
 
 define LIBPNG_STAGING_LIBPNG12_CONFIG_FIXUP
        $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" \
                -e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
-               -e "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include/libpng12\',g" \
+               -e "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include/libpng$(LIBPNG_SERIES)\',g" \
                -e "s,^libdir=.*,libdir=\'$(STAGING_DIR)/usr/lib\',g" \
-               $(STAGING_DIR)/usr/bin/libpng12-config
+               $(STAGING_DIR)/usr/bin/libpng$(LIBPNG_SERIES)-config
 endef
 
 LIBPNG_POST_INSTALL_STAGING_HOOKS += LIBPNG_STAGING_LIBPNG12_CONFIG_FIXUP