gettext: fixup library permissions
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 18 Sep 2013 13:38:01 +0000 (10:38 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Sep 2013 14:57:06 +0000 (16:57 +0200)
libintl.so* is installed without +x permissions thus preventing
stripping. Fix it up in the post install target hooks.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gettext/gettext.mk

index baf42efabe2918d0c75b7e9d233aea3174bf16f5..7af203551a2880db6fbde0e8eb93e549e8c9823d 100644 (file)
@@ -58,5 +58,12 @@ endef
 endif
 endif # GETTEXT_TOOLS = n
 
+# Library lacks +x so strip skips it
+define GETTEXT_FIX_LIBRARY_MODE
+       -chmod +x $(TARGET_DIR)/usr/lib/libintl.so*
+endef
+
+GETTEXT_POST_INSTALL_TARGET_HOOKS += GETTEXT_FIX_LIBRARY_MODE
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))