package/googlefontdirectory: silence false positive check-package warning
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Feb 2019 08:07:35 +0000 (09:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Feb 2019 08:07:35 +0000 (09:07 +0100)
check-package OverriddenVariable check believes we are overriding the
value of GOOGLEFONTDIRECTORY_LICENSE, but in fact we are not. Let's
tell check-package not to complain about this.

Fixes:

package/googlefontdirectory/googlefontdirectory.mk:28: unconditional override of variable GOOGLEFONTDIRECTORY_LICENSE previously conditionally set

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/googlefontdirectory/googlefontdirectory.mk

index f202d29c566902cc69837d8fe20655cbeb0687df..cf918ac4ae51d941f8ea08b34f16b182969eda86 100644 (file)
@@ -25,6 +25,7 @@ GOOGLEFONTDIRECTORY_LICENSE += UFL-1.1
 GOOGLEFONTDIRECTORY_LICENSE_FILES += $(addsuffix /LICENCE.txt,$(filter ufl/%,$(GOOGLEFONTDIRECTORY_FONTS)))
 endif
 
+# check-package OverriddenVariable
 GOOGLEFONTDIRECTORY_LICENSE := $(subst $(space),$(comma)$(space),$(GOOGLEFONTDIRECTORY_LICENSE))
 
 define GOOGLEFONTDIRECTORY_INSTALL_TARGET_CMDS