binutils: add 2.19.1
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Mar 2009 22:09:50 +0000 (22:09 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Mar 2009 22:09:50 +0000 (22:09 -0000)
toolchain/binutils/Config.in
toolchain/binutils/binutils.mk

index d3678896d408c0e03dd296f39dfb00f76080476a..a3d93ca28aef40485003db9ec6df7a2c983ff615 100644 (file)
@@ -4,7 +4,7 @@ comment "Binutils Options"
 
 choice
        prompt "Binutils Version"
-       default BR2_BINUTILS_VERSION_2_19
+       default BR2_BINUTILS_VERSION_2_19_1
        help
          Select the version of binutils you wish to use.
 
@@ -20,6 +20,7 @@ choice
 
        config BR2_BINUTILS_VERSION_2_18
                depends on !BR2_nios2
+               depends on BR2_DEPRECATED
                depends on BR2_EXT_BINUTILS_VERSION_2_18
                bool "binutils 2.18"
 
@@ -50,7 +51,13 @@ choice
 
        config BR2_BINUTILS_VERSION_2_19
                depends on !BR2_avr32 && !BR2_nios2
+               depends on BR2_DEPRECATED || BR2_RECENT
                bool "binutils 2.19"
+
+       config BR2_BINUTILS_VERSION_2_19_1
+               depends on !BR2_avr32 && !BR2_nios2
+               bool "binutils 2.19.1"
+
 endchoice
 
 config BR2_BINUTILS_VERSION
@@ -65,6 +72,7 @@ config BR2_BINUTILS_VERSION
        default "2.18.50.0.8"   if BR2_BINUTILS_VERSION_2_18_50_0_8
        default "2.18.50.0.9"   if BR2_BINUTILS_VERSION_2_18_50_0_9
        default "2.19"          if BR2_BINUTILS_VERSION_2_19
+       default "2.19.1"        if BR2_BINUTILS_VERSION_2_19_1
 
 config BR2_EXTRA_BINUTILS_CONFIG_OPTIONS
        string "Additional binutils options"
index 69819153db97c624b134579153d509411fb26bc3..27882521677ebaa46b89dce7699ed5b958075e5d 100644 (file)
@@ -9,6 +9,9 @@ BINUTILS_VERSION:=$(subst ",,$(BR2_BINUTILS_VERSION))
 EXTRA_BINUTILS_CONFIG_OPTIONS=$(strip $(subst ",, $(BR2_EXTRA_BINUTILS_CONFIG_OPTIONS)))
 #"))
 BINUTILS_SITE:=$(BR2_KERNEL_MIRROR)/linux/devel/binutils
+ifeq ($(BINUTILS_VERSION),2.19.1)
+BINUTILS_SITE:=$(BR2_GNU_MIRROR)/binutils/
+endif
 ifeq ($(BINUTILS_VERSION),2.19)
 BINUTILS_SITE:=$(BR2_GNU_MIRROR)/binutils/
 endif