package/libarchive: make optional zstd dependency explicit
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 7 Apr 2020 09:49:49 +0000 (11:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 8 Apr 2020 20:50:35 +0000 (22:50 +0200)
Otherwise, the presence of zstd support in libarchive will depend on build
order.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libarchive/libarchive.mk

index 60838eea0a56215447ea14ee4a4f32dcb237710a..94f974e7d1109df31a2c454c20edb5b0868250e5 100644 (file)
@@ -112,6 +112,13 @@ else
 LIBARCHIVE_CONF_OPTS += --without-lzma
 endif
 
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+LIBARCHIVE_DEPENDENCIES += zstd
+LIBARCHIVE_CONF_OPTS += --with-zstd
+else
+LIBARCHIVE_CONF_OPTS += --without-zstd
+endif
+
 # The only user of host-libarchive needs zlib support
 HOST_LIBARCHIVE_DEPENDENCIES = host-zlib
 HOST_LIBARCHIVE_CONF_OPTS = \