gst-plugins-base: tighten alsa dependency
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Nov 2010 21:33:25 +0000 (22:33 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Nov 2010 21:33:25 +0000 (22:33 +0100)
alsa support needs pcm+mixer support in alsa, but this isn't checked by
configure, so do it in the .mk instead.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/multimedia/gst-plugins-base/gst-plugins-base.mk

diff --git a/CHANGES b/CHANGES
index 6ca25bda9ab4220663db87d63bf1cd507bd50b4f..cc22bac8c2976226f649414e4d095528fcf66eb5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        bootutils, bridge-utils, bsdiff, busybox, cvs, dbus, directfb,
        dmraid, docker, dosfstools, dropbear, e2fsprogs, expat, ezxml,
        fbset, fconfig, ffmpeg, freetype, gadgetfs-test, gamin, gawk,
-       genext2fs, gperf, gst-plugins-ugly, gtk2-themes, gtkperf,
-       gvfs, haserl, hdparm, hostapd, hwdata, ifplugd, imagemagick,
-       iperf, ipsec-tools, iproute2, iptables, iw, jpeg, kexec,
-       kismet, less, libcgi, libcurl, libdaemon, libdnet, liberation,
-       libevent, libeXosip2, libglade, libgtk2, libiconv, libidn,
-       libintl, libmms, libmpd, libnl, liboil, libosip2, libpcap,
-       libpng, libtool, libungif, libxml2, libxslt, lighttpd, lite,
-       lm-sensors, lockfile-progs, logrotate, m4, mdadm, mesa3d,
-       metacity, mplayer, mtd-utils, mysql_client, nano, nbd, ncftp,
-       neon, netperf, netsnmp, ng-spice-rework, ntfsprogs, ntp,
-       openntpd, openssh, openssl, openvpn, oprofile, pango, patch,
-       pcre, php, pkg-config, pppd, prboom, radvd, rdesktop, ruby,
-       qt, quagga, samba, sawman, sdl_mixer, sdl_sound, setserial,
-       shared-mime-info, speex, sqlite, squashfs,
-       startup-notification, strace, sylpheed, taglib, tcpdump,
-       thttpd, tiff, tn5250, torsmo, udev, udpcast, usbmount,
-       usbutils, vsftpd, vtun, which, wpa_supplicant, xapp_twm,
-       xapp_xbacklight, xapp_xcursorgen, xapp_xinput, xapp_xmore,
+       genext2fs, gperf, gst-plugins-base, gst-plugins-ugly,
+       gtk2-themes, gtkperf, gvfs, haserl, hdparm, hostapd, hwdata,
+       ifplugd, imagemagick, iperf, ipsec-tools, iproute2, iptables,
+       iw, jpeg, kexec, kismet, less, libcgi, libcurl, libdaemon,
+       libdnet, liberation, libevent, libeXosip2, libglade, libgtk2,
+       libiconv, libidn, libintl, libmms, libmpd, libnl, liboil,
+       libosip2, libpcap, libpng, libtool, libungif, libxml2,
+       libxslt, lighttpd, lite, lm-sensors, lockfile-progs,
+       logrotate, m4, mdadm, mesa3d, metacity, mplayer, mtd-utils,
+       mysql_client, nano, nbd, ncftp, neon, netperf, netsnmp,
+       ng-spice-rework, ntfsprogs, ntp, openntpd, openssh, openssl,
+       openvpn, oprofile, pango, patch, pcre, php, pkg-config, pppd,
+       prboom, radvd, rdesktop, ruby, qt, quagga, samba, sawman,
+       sdl_mixer, sdl_sound, setserial, shared-mime-info, speex,
+       sqlite, squashfs, startup-notification, strace, sylpheed,
+       taglib, tcpdump, thttpd, tiff, tn5250, torsmo, udev, udpcast,
+       usbmount, usbutils, vsftpd, vtun, which, wpa_supplicant,
+       xapp_twm, xapp_xbacklight, xapp_xcursorgen, xapp_xinput,
+       xapp_xmore,
        xdriver_xf86-input-{acecad,aiptek,evdev,joystick,keyboard},
        xdriver-xf86-input-{mouse,synaptics,vmmouse,void},
        xdriver-xf86-video-{apm,ark,ast,ati,chips,cirrus,dummy,fbdev},
index 91d9f1b1d489523b158b156d403e709f1f319aea..e91d5fc0de0707f8601db1fde0826d25528acbc3 100644 (file)
@@ -25,8 +25,14 @@ GST_PLUGINS_BASE_CONF_OPT = \
                --disable-vorbistest \
                --disable-freetypetest
 
-GST_PLUGINS_BASE_DEPENDENCIES = gstreamer liboil \
-               $(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib)
+GST_PLUGINS_BASE_DEPENDENCIES = gstreamer liboil
+
+# alsa support needs pcm+mixer support, but configure fails to check for it
+ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
+GST_PLUGINS_BASE_DEPENDENCIES += alsa-lib
+else
+GST_PLUGINS_BASE_CONF_OPT += --disable-alsa
+endif
 
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ADDER),y)
 GST_PLUGINS_BASE_CONF_OPT += --enable-adder