package/gnuchess: add gettext dependency
authorRomain Naour <romain.naour@openwide.fr>
Sun, 10 May 2015 20:33:04 +0000 (22:33 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 11 May 2015 06:56:59 +0000 (08:56 +0200)
gnuchess check for libintl library if BR2_NEEDS_GETTEXT_IF_LOCALE is set.

checking for GNU gettext in libintl... yes
checking whether to use NLS... yes
checking where the gettext function comes from... external libintl
checking how to link with libintl... -lintl

But the dependency on gettext package is missing to ensures
reproducible builds.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gnuchess/Config.in
package/gnuchess/gnuchess.mk

index aa446f4b22cc2beaccab2a048206345971ebe62e..4993b1adf035df1989a060671d7a78ee2ea2b4a9 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_GNUCHESS
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS
        select BR2_PACKAGE_FLEX
+       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          GNU Chess lets most modern computers play a full game of chess.
 
index 48e8bc896533af28084bc050a28c0f5d33f9db86..0555cb17b4fcda9a4f26402a267c397005f47ce9 100644 (file)
@@ -10,6 +10,7 @@ GNUCHESS_LICENSE = GPLv2+
 GNUCHESS_LICENSE_FILES = COPYING
 
 GNUCHESS_DEPENDENCIES = host-flex flex
-GNUCHESS_DEPENDENCIES += $(if $(BR2_PACKAGE_READLINE),readline)
+GNUCHESS_DEPENDENCIES += $(if $(BR2_PACKAGE_READLINE),readline) \
+       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
 
 $(eval $(autotools-package))