package/openobex: depends on libusb-compat
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 17:34:51 +0000 (18:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 20:24:55 +0000 (21:24 +0100)
Openobex looks for libusb.pc provided by libusb-compat, not libusb-1.0.pc
provided by libusb:
https://github.com/zuckschwerdt/openobex/blob/master/acinclude.m4#L171

Openobex links against both libusb (libusb-1.0.so.0) and libusb-compat
(libusb-0.1.so.4):
$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/ircp | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libopenobex.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libusb-0.1.so.4]
 0x0000000000000001 (NEEDED)             Shared library: [libusb-1.0.so.0]
[...]

This patch changes the dependency in openobex.mk and also selects
libusb-compat.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openobex/Config.in
package/openobex/openobex.mk

index 2b8cf3820890329dda79197754b13b31ac1f595f..ed1b81fe424aeadff0388b6c1b4ef0534607c245 100644 (file)
@@ -22,8 +22,9 @@ comment "bluez support needs a toolchain w/ wchar, threads, dynamic library"
 
 config BR2_PACKAGE_OPENOBEX_LIBUSB
        bool "enable libusb support"
-       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
        select BR2_PACKAGE_LIBUSB
+       select BR2_PACKAGE_LIBUSB_COMPAT
 
 comment "libusb support needs a toolchain w/ threads"
        depends on !BR2_TOOLCHAIN_HAS_THREADS
index b50dbb7fd3248a4128f9b5fde714eba8fbf4ef97..6a1a10ba4f0198900c7443543d6f37ce33ec633d 100644 (file)
@@ -36,7 +36,7 @@ OPENOBEX_CONF_OPTS += --disable-bluetooth
 endif
 
 ifeq ($(BR2_PACKAGE_OPENOBEX_LIBUSB),y)
-OPENOBEX_DEPENDENCIES += libusb
+OPENOBEX_DEPENDENCIES += libusb-compat
 OPENOBEX_CONF_OPTS += --with-usb=$(STAGING_DIR)
 else
 OPENOBEX_CONF_OPTS += --disable-usb