package/systemd: remove SysV compatibility feature
authorNorbert Lange <nolange79@gmail.com>
Fri, 17 Jul 2020 23:43:12 +0000 (01:43 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 18 Jul 2020 20:43:25 +0000 (22:43 +0200)
Systemd enables compatibility with SysV services and utmp by default,
none of which is needed for buildroot as the packages' .mk will install
only the files for the chosen init system.

Furthermore, SysV support requires a setup where *both* /etc/init.d and
/etc/rc.d exists (the latter for the usual /etc/rcN.d). However, in
Buildroot, the latter does not exist; so we would not be able to provide
a working SysV support anyway.

So, just forcibly disable SysV support.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
[yann.morin.1998@free.fr:
  - expand commit log
  - disable utmp in its own patch
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/systemd/systemd.mk

index 570841ebe3476cd13b7015d558d8b3013474581f..733d170193babd8d12f773475521fbeb2cb536c8 100644 (file)
@@ -22,6 +22,8 @@ SYSTEMD_PROVIDES = udev
 
 SYSTEMD_CONF_OPTS += \
        -Drootlibdir='/usr/lib' \
+       -Dsysvinit-path= \
+       -Dsysvrcnd-path= \
        -Dblkid=true \
        -Dman=false \
        -Dima=false \