linphone: use external ortp/mediastreamer libraries
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 3 Jun 2012 19:25:00 +0000 (21:25 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Jun 2012 07:12:45 +0000 (09:12 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/linphone/Config.in
package/linphone/linphone.mk

index 31c28d8b4b04970220f0da77a5a55872144e08e1..1a6cfdb00b6d04de369a40f3ab546130da77b6b5 100644 (file)
@@ -2,6 +2,9 @@ config BR2_PACKAGE_LINPHONE
        bool "linphone"
        select BR2_PACKAGE_LIBEXOSIP2
        select BR2_PACKAGE_SPEEX
+       select BR2_PACKAGE_ORTP
+       select BR2_PACKAGE_MEDIASTREAMER
+       depends on BR2_INSTALL_LIBSTDCPP # mediastreamer
        help
          Linphone is an internet phone or Voice Over IP phone (VoIP).
 
@@ -19,3 +22,6 @@ config BR2_PACKAGE_LINPHONE
          client, linphonec, and video support is not enabled.
 
          http://www.linphone.org/
+
+comment "linphone requires a toolchain with C++ support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP
index 6ba6b533347b7b58e2756585b89f928698c2b4b5..b34fbf741b6a0de163a1cd02dfe2eaa35bfae54e 100644 (file)
@@ -6,7 +6,11 @@
 
 LINPHONE_VERSION = 3.5.2
 LINPHONE_SITE = http://download-mirror.savannah.gnu.org/releases/linphone/3.5.x/sources/
-LINPHONE_CONF_OPT = --disable-video --disable-gtk_ui
-LINPHONE_DEPENDENCIES = libeXosip2 speex
+LINPHONE_CONF_OPT = \
+       --disable-gtk_ui \
+       --enable-external-ortp \
+       --enable-external-mediastreamer
+
+LINPHONE_DEPENDENCIES = host-pkg-config ortp mediastreamer libeXosip2 speex
 
 $(eval $(call AUTOTARGETS))