freetype: explicitly en/disable dependencies
authorArnout Vandecappelle <arnout@mind.be>
Sat, 26 Oct 2013 22:44:54 +0000 (00:44 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Oct 2013 07:28:13 +0000 (08:28 +0100)
For the target, add --with/out to configure options as needed.

For the host, disable everything.

This was triggered by a failing build of the host package because it tried to
link the shared library with libbz.a, which isn't compiled with -fPIC.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freetype/freetype.mk

index 93fb3db8245831200042a49a9b102551d433b083..cc5fbf858c94bdd926a95c49f3a805274fa4681f 100644 (file)
@@ -13,13 +13,25 @@ FREETYPE_INSTALL_STAGING = YES
 FREETYPE_MAKE_OPT = CCexe="$(HOSTCC)"
 FREETYPE_LICENSE = Dual FTL/GPLv2+
 FREETYPE_LICENSE_FILES = docs/FTL.TXT docs/GPLv2.TXT
-FREETYPE_DEPENDENCIES = host-pkgconf \
-       $(if $(BR2_PACKAGE_ZLIB),zlib) \
-       $(if $(BR2_PACKAGE_BZIP2),bzip2)
+FREETYPE_DEPENDENCIES = host-pkgconf
 FREETYPE_CONFIG_SCRIPTS = freetype-config
 
 HOST_FREETYPE_DEPENDENCIES = host-pkgconf
-HOST_FREETYPE_CONF_OPT = --without-png
+HOST_FREETYPE_CONF_OPT = --without-zlib --without-bzip2 --without-png
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+FREETYPE_DEPENDENCIES += zlib
+FREETYPE_CONF_OPT += --with-zlib
+else
+FREETYPE_CONF_OPT += --without-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+FREETYPE_DEPENDENCIES += bzip2
+FREETYPE_CONF_OPT += --with-bzip2
+else
+FREETYPE_CONF_OPT += --without-bzip2
+endif
 
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 FREETYPE_DEPENDENCIES += libpng