icu: libatomic is only available starting from gcc 4.8
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 2 Feb 2016 15:31:19 +0000 (16:31 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 6 Feb 2016 10:16:00 +0000 (11:16 +0100)
Fixes:

  http://autobuild.buildroot.org/results/51b060bbdecdcaac89f764026693bf711e7145d5/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/icu/icu.mk

index 7bc7f938ecb9c6183b57562b8c4093f753492554..b4574e5be5dde4411b642c55dd90d86713b5709a 100644 (file)
@@ -18,10 +18,10 @@ ICU_CONF_OPTS = \
        --disable-samples \
        --disable-tests
 
-# With gcc >= 4.7, icu prefers to use C++11 atomics, which rely on the
+# When available, icu prefers to use C++11 atomics, which rely on the
 # __atomic builtins. On certain architectures, this requires linking
-# with libatomic.
-ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_4_7),y)
+# with libatomic starting from gcc 4.8.
+ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_4_8),y)
 ICU_CONF_ENV += LIBS="-latomic"
 endif