qt: fix build with gcc 4.6.x on arm
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 26 Feb 2012 21:23:45 +0000 (22:23 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 26 Feb 2012 21:30:12 +0000 (22:30 +0100)
As noted by Ismael Luceno. For details, see:
http://gcc.gnu.org/ml/gcc-patches/2010-11/msg02245.html

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 68f93483cee26d5a1d892641ea2806040e542567..776eb63afb50d8f20cbf4c61502e3cf348cfbae5 100644 (file)
@@ -201,6 +201,11 @@ endif
 
 ifeq ($(BR2_arm)$(BR2_armeb),y)
 QT_EMB_PLATFORM = arm
+ifeq ($(BR2_GCC_VERSION_4_6_X),y)
+# workaround for gcc issue
+# http://gcc.gnu.org/ml/gcc-patches/2010-11/msg02245.html
+QT_CXXFLAGS += -fno-strict-volatile-bitfields
+endif
 else ifeq ($(BR2_avr32),y)
 QT_EMB_PLATFORM = avr32
 else ifeq ($(BR2_i386),y)