libzip: add optional openssl support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 8 Jul 2018 07:36:46 +0000 (09:36 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 8 Jul 2018 10:17:45 +0000 (12:17 +0200)
openssl support has been added since version 1.5.0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libzip/libzip.mk

index d46bc179773bfdb91947ea911a98ead27430e5b1..0253a61cda7319e3062fc46bd41942e0b9b7d734 100644 (file)
@@ -18,4 +18,11 @@ else
 LIBZIP_CONF_OPTS += -DCMAKE_DISABLE_FIND_PACKAGE_BZIP2=TRUE
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBZIP_DEPENDENCIES += openssl
+LIBZIP_CONF_OPTS += -DENABLE_OPENSSL=ON
+else
+LIBZIP_CONF_OPTS += -DENABLE_OPENSSL=OFF
+endif
+
 $(eval $(cmake-package))