package/sofia-sip: fix build without openssl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 13 Sep 2020 16:52:26 +0000 (18:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 Sep 2020 20:03:49 +0000 (22:03 +0200)
HTTP-related modules are enabled by default and depend on openssl since
https://github.com/freeswitch/sofia-sip/commit/5b4103a12596ea01b4cdbb21b75826a085d557aa

Fixes:
 - http://autobuild.buildroot.org/results/95b6c489fed07d6fe626200ea057c83756d54deb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sofia-sip/sofia-sip.mk

index 0ce0340d87e050fec35474339bddd22fb4fd5512..ef1b35fa2c39a699a229616318d4e56addd01f7f 100644 (file)
@@ -20,10 +20,14 @@ SOFIA_SIP_CONF_OPTS += --without-glib
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
-SOFIA_SIP_CONF_OPTS += --with-openssl=pkg-config
+SOFIA_SIP_CONF_OPTS += \
+       --enable-nth \
+       --with-openssl=pkg-config
 SOFIA_SIP_DEPENDENCIES += openssl
 else
-SOFIA_SIP_CONF_OPTS += --without-openssl
+SOFIA_SIP_CONF_OPTS += \
+       --disable-nth \
+       --without-openssl
 endif
 
 ifeq ($(BR2_ENABLE_DEBUG),y)