package/bluez5_utils: ensure build order with the headers-only variant
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 21 Oct 2018 16:00:34 +0000 (18:00 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 21 Oct 2018 16:28:13 +0000 (17:28 +0100)
Since bluez5_utils and bluez5_utils-headers would install the same set
of files (headers), we want to ensure the former is run after the
latter.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Grzegorz Blach <grzegorz@blach.pl>
Cc: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/bluez5_utils/bluez5_utils.mk

index a613def2e27c4638b0114a5260c89dac9554d2f8..f5b827cc3080193b649a760c22e872c803647e35 100644 (file)
@@ -9,10 +9,14 @@ BLUEZ5_UTILS_VERSION = 5.50
 BLUEZ5_UTILS_SOURCE = bluez-$(BLUEZ5_UTILS_VERSION).tar.xz
 BLUEZ5_UTILS_SITE = $(BR2_KERNEL_MIRROR)/linux/bluetooth
 BLUEZ5_UTILS_INSTALL_STAGING = YES
-BLUEZ5_UTILS_DEPENDENCIES = dbus libglib2
 BLUEZ5_UTILS_LICENSE = GPL-2.0+, LGPL-2.1+
 BLUEZ5_UTILS_LICENSE_FILES = COPYING COPYING.LIB
 
+BLUEZ5_UTILS_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_BLUEZ5_UTILS_HEADERS),bluez5_utils-headers) \
+       dbus \
+       libglib2
+
 BLUEZ5_UTILS_CONF_OPTS = \
        --enable-tools \
        --enable-library \