projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d302583
)
make sure we have a directory before trying to install symlinks
author
Eric Andersen
<andersen@codepoet.org>
Fri, 7 Nov 2003 05:23:30 +0000
(
05:23
-0000)
committer
Eric Andersen
<andersen@codepoet.org>
Fri, 7 Nov 2003 05:23:30 +0000
(
05:23
-0000)
make/gcc-3.3.mk
patch
|
blob
|
history
diff --git
a/make/gcc-3.3.mk
b/make/gcc-3.3.mk
index 077e02a0af809a0fe14fe3783870fa5429195ff5..b00b3026dedd427774e38102f33ceb7fc7588a4f 100644
(file)
--- a/
make/gcc-3.3.mk
+++ b/
make/gcc-3.3.mk
@@
-290,7
+290,8
@@
$(TARGET_DIR)/lib/libstdc++.so.5.0.5: $(GCC_BUILD_DIR2)/.installed
$(TARGET_DIR)/lib/libgcc_s.so.0.9.9: $(GCC_BUILD_DIR2)/.installed
cp -a $(STAGING_DIR)/lib/libgcc_s.so* $(TARGET_DIR)/lib/
- # Enable applications to link with the shared ligbcc.
+ # Let applications link with the shared libgcc.
+ mkdir -p $(STAGING_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/
ln -sf $(STAGING_DIR)/lib/libgcc_s.so $(STAGING_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/libgcc.so
ifeq ($(INSTALL_LIBSTDCPP),true)