package/libplatform: bump version
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 2 Mar 2021 07:07:00 +0000 (08:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 6 Mar 2021 20:30:52 +0000 (21:30 +0100)
Add -std=c++11 to CXXFLAGS to fix build with gcc < 5.x:

buildroot/output/build/libplatform-a7cd0d5780ed80a4e70480d1650749f29e8a1fb2/src/util/StringUtils.cpp:
 In static member function 'static std::string& StringUtils::TrimLeft(std::string&)':
buildroot/output/build/libplatform-a7cd0d5780ed80a4e70480d1650749f29e8a1fb2/src/util/StringUtils.cpp:456:99:
 warning: lambda expressions only available with -std=c++11 or -std=gnu++11 [enabled by default]
   str.erase(str.begin(), ::find_if(str.begin(), str.end(), [](char s) { return isspace_c(s) == 0; }));
                                                                                                   ^
buildroot/output/build/libplatform-a7cd0d5780ed80a4e70480d1650749f29e8a1fb2/src/util/StringUtils.cpp:456:100:
 error: no matching function for call to 'find_if(std::basic_string<char>::iterator, std::basic_string<char>::iterator,
  StringUtils::TrimLeft(std::string&)::__lambda0)'
   str.erase(str.begin(), ::find_if(str.begin(), str.end(), [](char s) { return isspace_c(s) == 0; }));
                                                                                                    ^

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libplatform/libplatform.hash
package/libplatform/libplatform.mk

index f08435da12e785cf548620686866d13937aca610..283b435b7c868104e7e94a651275aa4d27e2468b 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  209daeb87af4ca92199887eb151b2a459bb81566cdaa092644e0889afb64bf6a  libplatform-1c9d14fa996af33760a2c700caebd2bd9ae527c9.tar.gz
+sha256  ebee46c76b86b40b703fa913465f5004fa3166eeb6a4794c58fc8a5c25702931  libplatform-a7cd0d5780ed80a4e70480d1650749f29e8a1fb2.tar.gz
 sha256  80fc66febbb2393c9d518e3eefa4ad9aae15a9b6a84174c0e443ea79eeea5131  src/os.h
index ca57a07d152fce9f36b3922b412bda15a0da3acd..5d909f784c68f7d07f342b7cb4fad7057c8f078e 100644 (file)
@@ -4,10 +4,14 @@
 #
 ################################################################################
 
-LIBPLATFORM_VERSION = 1c9d14fa996af33760a2c700caebd2bd9ae527c9
+LIBPLATFORM_VERSION = a7cd0d5780ed80a4e70480d1650749f29e8a1fb2
 LIBPLATFORM_SITE = $(call github,Pulse-Eight,platform,$(LIBPLATFORM_VERSION))
 LIBPLATFORM_LICENSE = GPL-2.0+
 LIBPLATFORM_LICENSE_FILES = src/os.h
 LIBPLATFORM_INSTALL_STAGING = YES
 
+ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_5),)
+LIBPLATFORM_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -std=c++11"
+endif
+
 $(eval $(cmake-package))