lftp: bump version to 4.7.2
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 23 May 2016 10:27:16 +0000 (11:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 May 2016 15:02:25 +0000 (17:02 +0200)
Help lftp to find readline and zlib so it will not fail this way:

checking for Readline... no
configure: error: cannot find readline library, install readline-devel
package

checking if zlib is wanted... yes
checking for inflateEnd in -lz... no
checking zlib.h usability... no
checking zlib.h presence... no
checking for zlib.h... no
configure: error: cannot find -lz library, install zlib-devel package

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
[Thomas: group zlib/readline options into one definition of
LFTP_CONF_OPTS.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lftp/lftp.hash
package/lftp/lftp.mk

index 4c5d799591eb713e8bc725504960835cc01c70f5..3185fc531df590d6180da12a303179f74096554b 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256  1e7cb674c83ace48172263f86847ed04bb6ab2f24116b11a8505f70a15e8805c  lftp-4.6.4.tar.xz
+sha256 475d7699b1390f951efee867ba1ad600f78329e13fd2a04d92f82bfffb70d872  lftp-4.7.2.tar.xz
index 5051f707a99290b6c6436e67c07698ab949723ef..c3c11c53b463c6c251a1bf3bdf1970cd053a172e 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LFTP_VERSION = 4.6.4
+LFTP_VERSION = 4.7.2
 LFTP_SOURCE = lftp-$(LFTP_VERSION).tar.xz
 LFTP_SITE = http://lftp.yar.ru/ftp
 LFTP_LICENSE = GPLv3+
@@ -13,6 +13,13 @@ LFTP_LICENSE_FILES = COPYING
 LFTP_AUTORECONF = YES
 LFTP_DEPENDENCIES = readline zlib host-pkgconf
 
+# Help lftp finding readline and zlib
+LFTP_CONF_OPTS = \
+       --with-readline=$(STAGING_DIR)/usr \
+       --with-readline-inc=$(STAGING_DIR)/usr/include/readline \
+       --with-readline-lib=$(STAGING_DIR)/usr/lib \
+       --with-zlib=$(STAGING_DIR)/usr
+
 ifneq ($(BR2_STATIC_LIBS),y)
 LFTP_CONF_OPTS += --with-modules
 endif