linux: ensure correct make targets are used for cuImage/simpleImage.<dtb>
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 6 May 2018 06:34:18 +0000 (08:34 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 6 May 2018 15:35:00 +0000 (17:35 +0200)
Fixes https://gitlab.com/buildroot.org/buildroot/-/jobs/66561794

LINUX_DTS_NAME may end up with a leading space because of the += logic, and
may contain multiple dts files - Neither of which works when we construct
the {cu,simple}Image.$(LINUX_DTS_NAME) make target name.

Fix it by using the first word in the variable.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index 9e646baffc68c617d1c32683d9320f670c6f0fdc..b6b91391b68956f90288687e6d6bcc82400b6250 100644 (file)
@@ -155,9 +155,9 @@ LINUX_IMAGE_NAME = zImage.epapr
 else ifeq ($(BR2_LINUX_KERNEL_APPENDED_ZIMAGE),y)
 LINUX_IMAGE_NAME = zImage
 else ifeq ($(BR2_LINUX_KERNEL_CUIMAGE),y)
-LINUX_IMAGE_NAME = cuImage.$(LINUX_DTS_NAME)
+LINUX_IMAGE_NAME = cuImage.$(firstword $(LINUX_DTS_NAME))
 else ifeq ($(BR2_LINUX_KERNEL_SIMPLEIMAGE),y)
-LINUX_IMAGE_NAME = simpleImage.$(LINUX_DTS_NAME)
+LINUX_IMAGE_NAME = simpleImage.$(firstword $(LINUX_DTS_NAME))
 else ifeq ($(BR2_LINUX_KERNEL_IMAGE),y)
 LINUX_IMAGE_NAME = Image
 else ifeq ($(BR2_LINUX_KERNEL_LINUX_BIN),y)