package/python3-requests: add special host variant
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 23 Mar 2020 10:49:06 +0000 (11:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 Apr 2020 13:16:17 +0000 (15:16 +0200)
Needed to build mongodb.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-requests/python-requests.mk
package/python3-requests/python3-requests.hash [new symlink]
package/python3-requests/python3-requests.mk [new file with mode: 0644]

index 1adf5640159b590e98ca537210e0706a88f2b051..9d36346b6502db7c2308a680c17101a4dcf59d86 100644 (file)
@@ -4,6 +4,7 @@
 #
 ################################################################################
 
+# Please keep in sync with package/python3-requests/python3-requests.mk
 PYTHON_REQUESTS_VERSION = 2.23.0
 PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
 PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/f5/4f/280162d4bd4d8aad241a21aecff7a6e46891b905a4341e7ab549ebaf7915
diff --git a/package/python3-requests/python3-requests.hash b/package/python3-requests/python3-requests.hash
new file mode 120000 (symlink)
index 0000000..19e182d
--- /dev/null
@@ -0,0 +1 @@
+../python-requests/python-requests.hash
\ No newline at end of file
diff --git a/package/python3-requests/python3-requests.mk b/package/python3-requests/python3-requests.mk
new file mode 100644 (file)
index 0000000..e2bb00e
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# python3-requests
+#
+################################################################################
+
+# Please keep in sync with package/python-requests/python-requests.mk
+PYTHON3_REQUESTS_VERSION = 2.23.0
+PYTHON3_REQUESTS_SOURCE = requests-$(PYTHON3_REQUESTS_VERSION).tar.gz
+PYTHON3_REQUESTS_SITE = https://files.pythonhosted.org/packages/f5/4f/280162d4bd4d8aad241a21aecff7a6e46891b905a4341e7ab549ebaf7915
+PYTHON3_REQUESTS_SETUP_TYPE = setuptools
+PYTHON3_REQUESTS_LICENSE = Apache-2.0
+PYTHON3_REQUESTS_LICENSE_FILES = LICENSE
+HOST_PYTHON3_REQUESTS_DL_SUBDIR = python-requests
+HOST_PYTHON3_REQUESTS_NEEDS_HOST_PYTHON = python3
+
+$(eval $(host-python-package))