gflags: new package
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>
Wed, 10 Jun 2015 05:50:48 +0000 (11:20 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 10 Jun 2015 07:39:46 +0000 (09:39 +0200)
Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
Reviewed-by: Abhimanyu Vishwakarma <abhimanyu.v@imgtec.com>
Reviewed-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/gflags/Config.in [new file with mode: 0644]
package/gflags/gflags.hash [new file with mode: 0644]
package/gflags/gflags.mk [new file with mode: 0644]

index e8a7d0ad38283c5db1eab45150c13108121a642f..a17901f6130d2627e0955e1e1227b98e68bae147 100644 (file)
@@ -1015,6 +1015,7 @@ menu "Other"
        source "package/elfutils/Config.in"
        source "package/fftw/Config.in"
        source "package/flann/Config.in"
+       source "package/gflags/Config.in"
        source "package/glibmm/Config.in"
        source "package/glm/Config.in"
        source "package/gmp/Config.in"
diff --git a/package/gflags/Config.in b/package/gflags/Config.in
new file mode 100644 (file)
index 0000000..ed05944
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_GFLAGS
+       bool "gflags"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         The gflags package contains a C++ library that implements
+         commandline flags processing. It includes built-in support for
+         standard types such as string and the ability to define flags
+         in the source file in which they are used.
+
+         https://github.com/gflags/gflags
+
+comment "gflags needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/gflags/gflags.hash b/package/gflags/gflags.hash
new file mode 100644 (file)
index 0000000..9c8b27a
--- /dev/null
@@ -0,0 +1,2 @@
+# No hash for v2.1.2, comes from the github-helper:
+none   xxx     gflags-v2.1.2.tar.gz
diff --git a/package/gflags/gflags.mk b/package/gflags/gflags.mk
new file mode 100644 (file)
index 0000000..661dad8
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# gflags
+#
+################################################################################
+
+GFLAGS_VERSION = v2.1.2
+GFLAGS_SITE = $(call github,gflags,gflags,$(GFLAGS_VERSION))
+GFLAGS_INSTALL_STAGING = YES
+GFLAGS_LICENSE = BSD-3c
+GFLAGS_LICENSE_FILES = COPYING.txt
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
+GFLAGS_CONF_OPTS = -DBUILD_gflags_LIB=OFF
+endif
+
+$(eval $(cmake-package))