ptpd2: fix static linking
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 30 Jul 2014 22:16:25 +0000 (19:16 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 31 Jul 2014 18:19:09 +0000 (20:19 +0200)
Do the same as in commit b64a06d7b70bd7b160826bf9b97e60e18171913d
to avoid missing libraries needed by libpcap. Fixes:
http://autobuild.buildroot.net/results/1a1/1a1dadfa2b22074d401b013606f0cede66efe826/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ptpd2/ptpd2.mk

index 3133726dd0f0fe379905c7cbe6459c2cecc978c7..6a6ae6092e94750c248bf37524fc1e6327e51941 100644 (file)
@@ -13,6 +13,10 @@ PTPD2_AUTORECONF = YES
 PTPD2_LICENSE = BSD-2c
 PTPD2_LICENSE_FILES = COPYRIGHT
 
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+       PTPD2_CONF_OPT += LIBS="$(shell $(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs)"
+endif
+
 ifeq ($(BR2_PACKAGE_NETSNMP),y)
        PTPD2_CONF_ENV += ac_cv_path_PATH_NET_SNMP_CONFIG=$(STAGING_DIR)/usr/bin/net-snmp-config
        PTPD2_DEPENDENCIES += netsnmp