subversion: needs sqlite and pkg-config
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Oct 2014 16:39:02 +0000 (17:39 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Oct 2014 16:41:42 +0000 (17:41 +0100)
Fixes:
http://autobuild.buildroot.net/results/de2/de243c429c1e443efdbba82a860dbb7a03d5b746/
http://autobuild.buildroot.net/results/40c/40ce377893789883503deaa57912b87d2e0192e8/
http://autobuild.buildroot.net/results/134/13449cd77fbbd1c2b21d04b1fc866a086d915353/
http://autobuild.buildroot.net/results/e3f/e3fc33177eef955830a7be68e7b23503fd1d9ebe/
and others.

Also add the missing 'select' statements for apr, expat and zlib to match
the .mk file.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/subversion/Config.in
package/subversion/subversion.mk

index cc2549f6626b2460ad194e2d5848fa0f440abcb9..dc04bdba5bebb1efd81a2ccc6f24b94b65757f6a 100644 (file)
@@ -1,11 +1,15 @@
 config BR2_PACKAGE_SUBVERSION
        bool "subversion"
+       select BR2_PACKAGE_APR
        select BR2_PACKAGE_APR_UTIL
        # apr really needs shared library support
        depends on !BR2_PREFER_STATIC_LIB
        depends on BR2_USE_MMU # apr
+       select BR2_PACKAGE_EXPAT
        select BR2_PACKAGE_NEON
        select BR2_PACKAGE_NEON_XML
+       select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_SQLITE
        help
          Subversion is an open source version control system
 
index af5244b1a9ada7dbda5f1f8b8f4706b775497289..5f37a87c7777907d94b9aaa6283b0646c2abeb07 100644 (file)
@@ -9,7 +9,7 @@ SUBVERSION_SITE = http://archive.apache.org/dist/subversion
 SUBVERSION_LICENSE = Apache-2.0
 SUBVERSION_LICENSE_FILES = LICENSE
 
-SUBVERSION_DEPENDENCIES = apr apr-util expat neon zlib
+SUBVERSION_DEPENDENCIES = host-pkgconf apr apr-util expat neon zlib sqlite
 SUBVERSION_CONF_OPTS = \
        --with-expat=$(STAGING_DIR)/usr/include:$(STAGING_DIR)/usr/lib: \
        --with-apr=$(STAGING_DIR)/usr \