pkg-autotools.mk: default host AUTORECONF{,_OPT} to the target values
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Oct 2013 21:37:58 +0000 (23:37 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Oct 2013 21:42:19 +0000 (23:42 +0200)
When we have patches touching configure.ac and hence need to set
<pkg>_AUTORECONF = YES we also have to remember to set
HOST_<pkg>_AUTORECONF = YES if we build both host and target versions,
which is often forgotten (latest case was bison).

Fix it by making the host versions of _AUTORECONF and _AUTORECONF_OPT
default to whatever the target versions are set to, similar to how we
handle a number of the other variables.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-autotools.mk

index b0edddebc7965956ea61a0de3a82fe4ebdb1fea2..95235298248a83a5c0e67bdd0a87b4f992f76771 100644 (file)
@@ -70,12 +70,19 @@ ifndef $(2)_MAKE
  endif
 endif
 
+ifndef $(2)_AUTORECONF
+ ifdef $(3)_AUTORECONF
+  $(2)_AUTORECONF = $($(3)_AUTORECONF)
+ else
+  $(2)_AUTORECONF ?= NO
+ endif
+endif
+
 $(2)_CONF_ENV                  ?=
 $(2)_CONF_OPT                  ?=
 $(2)_MAKE_ENV                  ?=
 $(2)_MAKE_OPT                  ?=
-$(2)_AUTORECONF                        ?= NO
-$(2)_AUTORECONF_OPT            ?=
+$(2)_AUTORECONF_OPT            ?= $($(3)_AUTORECONF_OPT)
 $(2)_INSTALL_OPT                ?= install
 $(2)_INSTALL_STAGING_OPT       ?= DESTDIR=$$(STAGING_DIR) install
 $(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install